Trouble with mysql database which can't get new table's info


#1

operating system:linux
metabase version:v0.32.1
mysql:mysql on cloud(aliyun)

this is my first time to install and use metabase.
i created a new mysql database connection,then i could saw all the tables at first.
but when i create a new table,i can’t see this table at all.even i refresh or log out,i just can’t see the new table.


#2

Hi @luoka
I would suggest that you upgrade to 0.32.3, which was released yesterday.
When you make changes to your database, then you need to synchronize - Settings > Admin > Databases > (database) > Sync database schema now.
Read more here: https://www.metabase.com/docs/latest/administration-guide/01-managing-databases.html
And if you have tried to sync, but nothing shows up, then check the logs.


#4

i had tried to sync,but not work.this is my logs:

![2|690x208]
i will have a try to upgrade to 0.32.3


#5

@luoka
Have a look in the logs - there’s much more details.


#6


Those are the whole logs.
"WARN metabase.util.date :: 数据库时区冲突 jvm域数据库时区不一致 正确配置报表的日期格式 "
This waring means that database’s time zone is different.
Could this be the reason?


#7

I’m not sure. I don’t understand the Chinese log.
The timezone warning, should not be an issue.
From what I can see, it’s synchronizing the table dw.


#8

This problem suddenly be sloved after i migrate metabase’s database from H2 to MySQL.
Miraculous!
Thank you for your reply.