Try out the new 0.42 release

Hi all :wave:

We've just released 0.42.1, which we would love if you would try and provide feedback on.

Download links and extensive changelog.
The free open source edition:
Enterprise/Pro edition:

Please make sure you have backups before upgrading.

1 Like

Just replaced the 0.42 version of metabase.jar

@beta It's a warning. Those are also displayed currently. Nothing new about 0.42.0-rc1


I´m trying out the 0.42.0-rc1 version. I loved all the possibilities created by the models building block for data management and data stewardship.

Congratulations to Metabase's team. I would love to see model´s metadata evolve to include PII classification, dataset and columns tags, and data ownership.

So i started trying out the 'modal' function.
I save the question as a modal.

Then when i open the modal again, and trying to do a join or adding a filter, i get an error message.
"ERROR: column source.betaalmiddel does not exist Position: 2836"

"browser-info": {
"language": "nl-NL",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.2 Safari/605.1.15",
"vendor": "Apple Computer, Inc."
"system-info": {
"file.encoding": "Cp1252",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "",
"java.vendor": "AdoptOpenJDK",
"java.vendor.url": "",
"java.version": "",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "",
"": "Windows 10",
"os.version": "10.0",
"user.language": "nl",
"user.timezone": "Europe/Paris"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "13.2"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.23"
"run-mode": "prod",
"version": {
"date": "2022-01-20",
"tag": "v0.42.0-rc1",
"branch": "release-x.42.x",
"hash": "2af85ba"
"settings": {
"report-timezone": "Europe/Brussels"

@cobalt Are you referring to "Models"? We just fixed a bunch of nested query issue the last couple of days and it sounds like you are hitting one of those.

Can you show a screenshot of your Notebook, so I can see how the Model(question) is constructed?
Alternatively use the Sample Dataset.

I'm guessing that you could likely reproduce the same error with a regular question used several times in Saved Questions.

I will just wait for the next update then to try it further :slight_smile:

Is there any ETA for an update?
Want to test it out the models feature, but it's already broken for me at the first step.
As flamber said, you guys already did some fixes.. is there a new RC coming out? Or is it waiting for the full release now ?

@cobalt We are working on finishing several PRs, so there might be a RC2. This topic will be updated.

1 Like

Just been playing with v0.42.0-rc2 and a couple of things surprised me.

First the new format of pinned questions was unexpected, I like the idea but I think I'd also like an option to not execute the query or render the question in some cases. Some of our questions are very heavy/slow (not the fault of Metabase) and I feel like executing them just to browse the collection tree may not be desirable. It looks like you can get multiple instances of a query firing at the same time just by browsing to the collection where they are pinned a few times. Pinning used to be a good way of highlighting a few questions, the new pinning feels like it's doing something different. I'd like to be able to do both.

Another one that surprised me was the "New > Question" taking me straight to the notebook builder. Some of our users are not super confident with the notebook builder (they're not particularly technical and are coming from Excel), they are more comfortable starting from the visible table of data and using the simplified interface to filter and group, they can see the effect of the changes they are making as they go. I know they can just click the "Hide editor" button, or go straight to "Visualise" but it's a change of habit. This will be an education thing for us, getting them comfortable with the notebook builder, but thought I'd provide feedback.

Really like the new summarise sidebar, makes it much more obvious what the groupings are. Although I do note that I need to close and reopen the sidebar for the grouped by fields to appear a the top. Small gripe but really like the change.

Models look amazing. I'll definitely be refactoring a few saved questions and questions based on them to make use of this. It's a very good addition.

Expression editor feels better, faster and more responsive.

As always, keep up the good work!

We're having some issues interacting with the Slack integration.

Created app successfully and it is able to send dashboard subscriptions fine - but after adding it to channels it doesn't seem to respond to @Metabase help or metabot help etc. Any ideas? Potentially a network permissions issue on our side - but since it can post subscriptions fine, seems unlikely?

Any pointers/suggestions would be appreciated :slight_smile:

I also installed RC2 to test out the models again, but still not usable for me.
As soon as I do a JOIN in it, it's broken.

Edit: actually it's always broken for me. (same error as I posted earlyer)

@cobalt Please add the Sample Database and provide steps to reproduce.

@geoffcowan The MetaBot has been completely removed.

@flamber - well that explains that, thanks !

I'm unable to reproduce on that database, but i did find the reason of breaking.
The error was always pointing to a specific field missing.
""ERROR: column source.betaalmiddel does not exist Position: 2836""

So i checked the datamodel and it was set at 'Category' and show values: use custom mapping.
When i disabled the custom mapping and recreated the model, i got the same error on an other field with the same field settings.

I also removed the custom mapping, recreated the model and i was able to do it.

I tried to break it in the sample databases, but i did not succeed.

Important to know, i had to create the model over and over again. If i used a model i created before the 'fix' , it was still broken.

@cobalt Sounds a lot like, which didn't make it into rc2 and currently unsure if it will go into 0.42.0 or later.

5 posts were merged into an existing topic: Custom column as date

Hey ! May I kindly ask why ? It looked like a cool feature to me. Also, I thought migrating to a slack app would bring more capabilities... but I can't see (yet) the advantages.

@mazzma12 It was legacy code, so it would need a full re-write to work correctly without all the known problems, and too few people were using it and was difficult to manage permissions for.

There's no real advantages to the shift to App - which is also why we kept using the Bot implementation.