Unable to change display values in display model

I'm unable to change the display values on a column in the display model.
The only option available is "Use original values".

There is data in these colomn, i have it in multiple columns.
Before this issue, i had the issue that it was not saving the values, they were always gone after a refresh of the page.

I'm on the latest version.

{
"browser-info": {
"language": "nl-NL",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.77 Safari/537.36",
"vendor": "Google Inc."
},
"system-info": {
"file.encoding": "Cp1252",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.11+9",
"java.vendor": "AdoptOpenJDK",
"java.vendor.url": "https://adoptopenjdk.net/",
"java.version": "11.0.11",
"java.vm.name": "OpenJDK Client VM",
"java.vm.version": "11.0.11+9",
"os.name": "Windows Server 2016",
"os.version": "10.0",
"user.language": "en",
"user.timezone": "Europe/Paris"
},
"metabase-info": {
"databases": [
"postgres"
],
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "10.12"
},
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.18"
}
},
"run-mode": "prod",
"version": {
"date": "2021-05-27",
"tag": "v0.39.3",
"branch": "release-x.39.x",
"hash": "598a112"
},
"settings": {
"report-timezone": "Europe/Brussels"
}
}
}

Hi @timothyv
Metabase can currently only do remapping on numeric columns.
Can you post the details for the field from /api/field/:id where :id is the field ID, which you can see in the URL, when viewing the column details pages in Data Model.

Hi, i'm not sure what you want me to do, i guess an api call?
I don't know how to do that.. i'm sorry.

But i can confirm to you that it is an numeric column as i did it before on the same column on a previous version.
I also was able to do it in this version, but had issues that it was not saving the values, and suddenly i was not able at all to set values.
I tried a lot of dropping the saved values and rescanning the field.

@timothyv So when I go to Admin > Data Model > (db) > (table) > (column) :gear:, then the URL looks like this: /admin/datamodel/database/4/table/11/83/general
Now change the URL to /api/field/83 - where 83 is the column that I want to look at, which will be different on your system.

@flamber
thanks for clearing that up.

Here you go:

{"description":null,"database_type":"int4","semantic_type":"type/Category","table_id":68,"coercion_strategy":null,"table":{"description":"Alle registraties van op de recyclageparken.","entity_type":"entity/GenericTable","schema":"public","db":{"description":null,"features":["full-join","basic-aggregations","standard-deviation-aggregations","expression-aggregations","percentile-aggregations","foreign-keys","right-join","left-join","native-parameters","nested-queries","expressions","set-timezone","regex","case-sensitivity-string-filter-options","binning","inner-join","advanced-math-expressions"],"cache_field_values_schedule":"0 0 19 * * ? *","timezone":"Europe/Paris","auto_run_queries":true,"metadata_sync_schedule":"0 55 * * * ? *","name":"RecySoft","caveats":null,"is_full_sync":true,"updated_at":"2021-05-28T10:05:48.481038Z","details":{"additional-options":null,"ssl":false,"instance":"SQLEXPRESS14","db":"Recyclagepark","password":"MetabasePass","port":5432,"dbname":"Recyclagepark","host":"localhost","tunnel-enabled":false,"user":"postgres"},"is_sample":false,"id":2,"is_on_demand":false,"options":null,"engine":"postgres","refingerprint":null,"created_at":"2021-03-05T14:04:02.383345Z","points_of_interest":null},"show_in_getting_started":false,"name":"registration","caveats":null,"updated_at":"2021-03-16T07:33:43.107689Z","entity_name":null,"active":true,"id":68,"db_id":2,"visibility_type":null,"field_order":"database","display_name":"registratie","created_at":"2021-03-05T14:04:03.251606Z","points_of_interest":null},"name":"paytype","fingerprint_version":5,"has_field_values":"none","settings":null,"caveats":null,"fk_target_field_id":null,"dimensions":[],"updated_at":"2021-05-28T11:09:41.511604Z","custom_position":0,"effective_type":"type/Integer","active":true,"parent_id":null,"id":828,"last_analyzed":"2021-03-05T14:04:43.272469Z","position":28,"visibility_type":"normal","preview_display":true,"display_name":"betaalmiddel","database_position":28,"name_field":null,"fingerprint":{"global":{"distinct-count":3,"nil%":0.0},"type":{"type/Number":{"min":0.0,"q1":0.0,"q3":2.232636399702163,"max":3.0,"sd":1.3357889778027523,"avg":1.0068}}},"created_at":"2021-03-05T14:04:05.194616Z","base_type":"type/Integer","points_of_interest":null}

@timothyv I have never noticed this problem before, but it has existed for a long time. See the issue I just created for workaround:
https://github.com/metabase/metabase/issues/16322 - upvote by clicking :+1: on the first post

1 Like

@flamber
Thanks for the work-around. It works like that.