Unable to configure HTTPS

Hi , I have some issue while configuring HTTPS for metabase .I followed the guide provided in the manual.

I run the following before starting Metabase :
export MB_JETTY_SSL=“true”
export MB_JETTY_SSL_Port=“8443”
export MB_JETTY_SSL_Keystore="/home/keystore.jks"
export MB_JETTY_SSL_Keystore_Password=“pass”

I created the pks in the keystore using the crt I also have a key and p12 files which was not used in the jks creation process .

While running metabase i see this log:

05-18 13:47:38 INFO metabase.util :: Loading Metabase…
05-18 13:47:42 INFO util.encryption :: DB details encryption is DISABLED for this Metabase instance. ��
See http://www.metabase.com/docs/latest/operations-guide/start.html#encrypting-your-database-connection-details-at-rest for more information.
05-18 13:47:49 INFO metabase.core :: Starting Metabase in STANDALONE mode
05-18 13:47:49 INFO metabase.core :: Launching Embedded Jetty Webserver with config:
{:port 3000, :ssl? true, :ssl-port 8443, :keystore “/home/keystore.jks”}

but when i try to launch the metabase site using the URL https://metabase:8443 and http://metabase:8443, and none of them work . Can someone provide some help in this regard on how to configure HTTPS.
Thanks in Advance.

Huh? That doesn’t sound right to me. As far as I know you need the private key in the keystore as well. The public certificate alone is not enough.

edit: ah wait, looked at bit more at the Gist below - at it seems to be probing through a running webserver - which you don’t have yet. Probably a better starting point would be https://confluence.atlassian.com/jirakb/checking-ssl-keystore-for-imported-certificates-639238418.html - this page mentions in the example output that you should see Entry type: PrivateKeyEntry when testing your keystore …

When I googled https://www.google.com/search?q=test+keystore+certificate the first thing it spat out was this (which I must admit I havn’t tried – yet):

… let us know how it goes …