Unable to connect to Azure Synapse SQL database

Hi all,

I'm trying to connect to an Azure Synapse SQL Pool endpoint but I get an error saying "Failed to load MSAL4J Java library for performing ActiveDirectoryPassword authentication.", I have filled out the JDBC connection details as I would normally do but it doesn't like the additional option provided. Has anyone tried to connect to one of these databases before? Technically, it should be the same as connecting to a normal Azure SQL database.

The config

The error.
image

Bump. Hoping someone can help me out, still no luck with this issue

I guess this is what happens at the bleeding edge!

I've not used it but I have used MS SQL in just about every other guise.

Standard troubleshooting, start with connecting from SSMS, then ODBC, then JDBC using something else.

I'd also try using non-AD security in case that's the problem.

Thanks for your reply, indeed I'm finding this to be a challenge in Superset as well (different issue though) and very little documentation exists for it.

I've managed to set up successful connections using SSMS, JDBC (python), etc from another PC, all using the 'authentication=ActiveDirectoryPassword' parameter. Unfortunately, we don't have the option to use non-AzureAD accounts.