Unable to connect to spark sql

Currently our spark thrift server is running on k8 pod and after doing port forwarding I am able to host the service in localhost and able to connect from my locally installed beeline via localhost and on port 8084

beeline> !connect jdbc:hive2://localhost:8084
Connecting to jdbc:hive2://localhost:8084
Enter username for jdbc:hive2://localhost:8084: 185
Enter password for jdbc:hive2://localhost:8084: ***
log4j:WARN No appenders could be found for logger (org.apache.hive.jdbc.Utils).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Connected to: Spark SQL (version 3.3.2)

However when I provide the same information on spark sql connection like host as localhost and port as 8084 , getting the error - "Hmm, we couldn't connect to the database. Make sure your Host and Port settings are correct"

error I am getting

Caused by: java.sql.SQLException: Could not open client transport with JDBC Uri: jdbc:hive2://localhost:8084/default: java.net.ConnectException: Connection refused (Connection refused)
at org.apache.hive.jdbc.HiveConnection.(HiveConnection.java:256)
at metabase.driver.hive_like.fixed_hive_connection.proxy$org.apache.hive.jdbc.HiveConnection$ff19274a.(Unknown Source)
at metabase.driver.hive_like.fixed_hive_connection$fixed_hive_connection.invokeStatic(fixed_hive_connection.clj:9)
at metabase.driver.hive_like.fixed_hive_connection$fixed_hive_connection.invoke(fixed_hive_connection.clj:9)
at metabase.driver.sparksql.SparkSQLDataSource.getConnection(sparksql.clj:97)
at clojure.java.jdbc$get_connection.invokeStatic(jdbc.clj:372)
at clojure.java.jdbc$get_connection.invoke(jdbc.clj:274)
at clojure.java.jdbc$db_query_with_resultset_STAR_.invokeStatic(jdbc.clj:1111)
at clojure.java.jdbc$db_query_with_resultset_STAR_.invoke(jdbc.clj:1093)
at clojure.java.jdbc$query.invokeStatic(jdbc.clj:1182)
at clojure.java.jdbc$query.invoke(jdbc.clj:1144)
at clojure.java.jdbc$query.invokeStatic(jdbc.clj:1160)

it's a connection refused, have you tried connecting with another client?

Yes , I was able to successfully connect via beeline from the same local where I was trying with metabase. I have also pasted the log of beeline in the original thread .

I have also tried with telnet as well and that is also working

So Metabase is running locally as a JAR?

I am running metabase as a docker container in local