Unable to use regexextract function to create custom columns

Recently, when creating custom columns in the GUI view, using the regexextract function is resulting in the error "Unsupported function regex-match-first", which is preventing me from saving the updates.

However, some of the previous questions I created that used the regexextract function are still working normally.

Have any of you encountered this situation before? How can I resolve this problem? I would greatly appreciate any help from the community!

Can you share the custom column expression so i can run it from my side?

Thank you for the response, Tony.

My expression is as follows:

substring(regexextract([headers], "\"fileKey\"\s*:\s*\"([^\"]+)"), 13, 50)

Hmmmm, no errors from my end:

What version are you running? Can you upgrade to 1.49.5?

My current version is 0.49.5, and it indicates that this is the latest version.
Is there any setting I can adjust to control whether the regular expression function is enabled?

No not really.

Can you share what Database you are using and what data type is the column

MySQL,and the date type of this column is json.

Moreover, I have also tried using the regexextract expression on other data tables and column of different types, but I keep getting the same error message. Additionally, when entering the expression, I don't receive any input suggestions like I do with other expressions. It feels as if Metabase doesn't support this expression at all.

You are saying if you write this it doesn't pop up?

Can you share a similar screenshot to mine please

here is the screenshot:

Strange ... Can you share Admin -> Troubleshooting -> Diagnostic Info

Sure, is this it?

  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/17.4.1 Safari/605.1.15",
    "vendor": "Apple Computer, Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.22+7-post-Ubuntu-0ubuntu222.04.1",
    "java.vendor": "Ubuntu",
    "java.vendor.url": "https://ubuntu.com/",
    "java.version": "11.0.22",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.22+7-post-Ubuntu-0ubuntu222.04.1",
    "os.name": "Linux",
    "os.version": "6.2.0-1017-aws",
    "user.language": "en",
    "user.timezone": "Etc/UTC"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "mysql",
    "application-database-details": {
      "database": {
        "name": "MySQL",
        "version": "8.0.35"
      "jdbc-driver": {
        "name": "MariaDB Connector/J",
        "version": "2.7.10"
    "run-mode": "prod",
    "version": {
      "date": "2024-04-11",
      "tag": "v0.49.5",
      "hash": "31c4887"
    "settings": {
      "report-timezone": null

All looks fine, I am really lost here ... Does it happen to every question? ... Can you share the whole screenshot of the GUI please.

Start just with a table and then try to apply the function

Yes, I am quite perplexed as well, this is really quite counter-intuitive. :joy:

out of curiosity can you just try to do this in incognito

how to do this in incognito?

I haven't really operated something like this before.

No no what i mean is using private browser (or incognito)

So we make sure there are no plugin or cached stuff interfering

got it.
I tried both Safari and Chrome, but it still won't work.:sob:

Aaaaa -.- ... Can you go to Admin -> Databases and share with me a similar screenshot:

Want to confirm you are indeed connected to MYSQL ... and what other DBs you have, you mentioned redshift can you try the regex command on a redshift table as the source

I am using the PLAUD.AI database.

Hmmm and what is the MYSQL version of that Database?