Unable to visualize as Trend with Druid

Hi,

I will try to use trend, by I can only with the sample data, with druid not work. Any Ideas?

With the sample data:
All ok, I can only put one image.

with druid:
54

And the error says: “Agrupa por un campo temporal para ver como ha cambiado a lo largo del tiempo”.

But I already did it, just like with the sample data and it worked.

Sorry, i want put metabase in English, but by default appear in Spanish in docker (I change it, but not work).

The same thing happens to me with this other visualization

Thanks!!!
Regards

My Conf:
{
“browser-info”: {
“language”: “es-ES”,
“platform”: “MacIntel”,
“userAgent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36”,
“vendor”: “Google Inc.”
},
“system-info”: {
“java.runtime.name”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “11.0.5+10”,
“java.vendor”: “AdoptOpenJDK”,
“java.vendor.url”: “https://adoptopenjdk.net/”,
“java.version”: “11.0.5”,
“java.vm.name”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “11.0.5+10”,
“os.name”: “Linux”,
“os.version”: “4.15.0-91-generic”,
“user.language”: “en”,
“user.timezone”: “GMT”
},
“metabase-info”: {
“databases”: [
“h2”,
“druid”
],
“hosting-env”: “unknown”,
“application-database”: “h2”,
“application-database-details”: {
“database”: {
“name”: “H2”,
“version”: “1.4.197 (2018-03-18)”
},
“jdbc-driver”: {
“name”: “H2 JDBC Driver”,
“version”: “1.4.197 (2018-03-18)”
}
},
“run-mode”: “prod”,
“version”: {
“date”: “2020-02-25”,
“tag”: “v0.34.3”,
“branch”: “release-0.34.x”,
“hash”: “1a83edb”
},
“settings”: {
“report-timezone”: null
}
}
}

I am using druid and there are no problem for trending chart… Below is my sample chart

image

Hi,

I want this… in my case only fail with driud. Do you have metabase in docker?

Thanks for the reply!
Regards

Sorry for late reply. No, i not using docker
Gauge chart should work also if u use custom query direct. Just to reconfirm is ur timestamp data type in date format?

I ran into the same issue. Here is how I solved it:

  • Admin -> Data Model -> [your DB] -> [your_datasource]
  • Scroll down to your “timestamp” field
  • Change the type to either a date or a timestamp (I used “Creating timestamp”)

You should now be able to use the “Trends” visualization.