Unauthenticated error on action button in an embedded dashboard

We just started evaluating action buttons and it is a pretty cool feature. It worked well on an embedded dashboard but suddenly we started getting an "unauthenticated" error. The model is enabled on the database. Are we missing something?


Edit: Chrome console debug shows this error:
Failed to load resource: the server responded with a status of 401 (Unauthorized) for /api/database/33:1

is there any way you could give us repro steps?

Here are the steps to replicate the issue:

  1. Create a Question, e.g. Simple question created from the sample database Accounts table. Add it to a dashboard.
  2. Turn the question into a model
  3. Create a simple action. e.g. Select 'a'
  4. Add an action Button to the dashboard and assign the simple action.
  5. Publish the dashboard publicly and check whether the action button works in the browser's Private mode. The action button shows unauthenticated. The same repeats if you try signed embedding

Wondering if this is by design or error on our side?

I have the same error, I tried to use the "Embed in your application" option instead of the "Public embed" option but the error remains, did you manage to solve it?

Not yet. I came to conclusion that this is not possible at this point. Actions is still a new feature and possible that this hasn’t been ironed out. You can publish action form as public (see action documentation) and that works but action button stays disabled in public or embedded dashboards.