Unknown log format "healthd"

Hi all,

I was wondering if any of you has come accross the issue of unknown log format while setting up Metabase on an AWS EB?
I’m using the link provided but the guide seems outdated. Perhaps a specific config no preset in the aws direct link that I am missing?

Hey Johan -

Is this on a fresh installation or an upgrade? We’ve seen that internally on one beanstalk environment we tried to upgrade that was about 2 years old, and haven’t been able to replicate it on other instances. If it’s happening to you, we’d love to get to the bottom of it.

It has something to do with the nginx reverse proxy configuration, but we haven’t been able to nail down exactly what is happening. We’ve tried to explicitly define that log format and got a “log format already defined” error when we did that. It goes away if you don’t use nginx as a reverse proxy and just terminate SSL, etc on the ELB.

Hi Smaeer, thanks for your reply, although this is not an upgrade, it’s a fresh install.
Basically just navigated to the EB link porvided in the guide and then just added the following things:

-Added username and passwrd for the DB
-Added email for the notifications

After that, it throws that error.

Would you be willing to hop on a video call and screenshare with us?

Trying to repro in the meantime. Which Availability zone are you in?

Ok, to add to the hilarity, I and another team member tried to reproduce this. One of us got hit by that error and the other didn’t. It’s … vexing.

Ok, we’ve figured it out

@johan if you go to “Config” on your non-working environment and select enable “enhanced health” under health checks things work.

Amazon is redesigning the beanstalk UI and that redesign seems to have broken our pre-baked template. We’ll fix that but in the meantime you should be able to get things going if you do the above.

This is great, I also saw that in the setup guide, there is a bit of a confusing part which asks for the health check URL to be set to /api/health, just for your consideration :slight_smile:
Now everything is working well. Thanks a lot!

For you and anyone who’s had issues with this, we just release 0.25.1 which fixes this (though at the cost of making enhanced health monitoring a little less useful).

I am not able to get the upgrade to work on BeanStalk with either v0.25.0 or V0.25.1.