Upgrade to 43.2 from 42.1 Chrome becomes unresponsive

Last night I upgraded from 43.2 to 42.1. I have a report that has about 19 cards on it. It relatively quickly loads 18 of the 19 cards as stated in the browser tab but then the last lab tab takes quite a while to load. I am not able to scroll up and down for about one to two minutes until it fully loads. Once it fully loads I can scroll up and down but the general UI for Metabase is almost unresponsive. If I try to click a button or something else in the application it takes 5 to 10 seconds to respond. I have tried this on a few different computers Mac and PC. The PC has 32 gigs of ram so I'm not sure that this is a ram issue. Also, I'm using the latest version of chrome. I tried Firefox on the PC and had a similar issue. It feels like a client-side issue but this report has been running fine for six months. Even after it fully loads if I go back to the browser it has delayed scrolling and delayed interaction. Almost like my computer is short on resources.
The only thing that changed yesterday was the upgrade. I removed the long-running report card and it still takes quite a while to load. Some cards don't populate very quickly with the bar charts as they used to. No significant changes in underlying data. Any thoughts?

It is running in AWS on beanstalk with Postgres config db hitting SQL Server sources. Below is the diagnostic info. I was running t3.small instance in RDS. Upgraded to t3.medium and no change in load performance.

"browser-info": {
"language": "en-US",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.15+10",
"java.vendor": "Eclipse Adoptium",
"java.vendor.url": "https://adoptium.net/",
"java.version": "11.0.15",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.15+10",
"os.name": "Linux",
"os.version": "4.14.276-211.499.amzn2.x86_64",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "11.15"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.3.2"
"run-mode": "prod",
"version": {
"date": "2022-05-31",
"tag": "v0.43.2",
"branch": "release-x.43.x",
"hash": "433d533"
"settings": {
"report-timezone": null

Hi @Slickrock22
It sounds like a frontend rendering issue. Check your browser's developer Performance-tab.

Not really sure how to interpret this. Is the info helpful? What should I look for?

@Slickrock22 It looks like it's chocking on some javascript, but cannot see the details.
Can you include your dashboard construction?

SELECT "report_dashboardcard"."id", "report_dashboardcard"."card_id", "report_dashboardcard"."col", "report_dashboardcard"."row", "report_dashboardcard"."sizeX", "report_dashboardcard"."sizeY", coalesce("report_card"."display", 'textbox') as "viz"
FROM "report_dashboardcard"
LEFT JOIN "report_card" ON "report_card"."id"="report_dashboardcard"."card_id"
WHERE "report_dashboardcard"."dashboard_id" = REPLACE_WITH_YOUR_DASHBOARD_ID

Or try to reproduce with Sample Database and construct a similar dashboard and open an issue.

Is this what you need?

740 725 0 26 18 5 area
742 727 0 37 18 5 area
677 552 0 73 18 5 area
739 724 0 21 18 5 area
559 545 0 0 18 5 area
743 728 0 42 18 5 bar
558 528 15 5 3 4 scalar
729 715 0 78 18 6 area
744 729 0 47 18 5 bar
562 550 0 5 15 4 line
745 730 0 57 18 5 bar
730 0 72 18 1 textbox
746 731 0 62 18 5 bar
623 616 0 9 18 6 bar
747 732 0 67 18 5 bar
624 525 0 15 18 6 area
748 733 0 52 18 5 bar
741 726 0 31 18 6 area
749 663 0 84 18 26 table

@Slickrock22 Well, it gives me a little information to work with, but you can try to reproduce with Sample Database.
Can you paste it as text, so I don't have to manually input from an image?

Sorry I'm not exactly sure what you mean by trying to reproduce it with the sample database. Text table added to the previous post.

@Slickrock22 Try to use the Sample Database that Metabase provides (Admin > Databases) and try to reproduce a slow dashboard, then it's a lot easier for everyone to reproduce, since most people don't want to share their dashboards with real data.

Recreating using the Sample DB looks like a near-impossible feat. Is there any other way to share performance data? Happy to jump on zoom if you think it may be a Metabase issue. Just weird that it has worked fine until the upgrade.

@Slickrock22 Check if there's any performance changes on databases and network.
Then downgrade to 42.4 to test.