Upgraded then downgraded version for metabase but getting error

We were on 0.41.5 version and upgraded our version to the latest one (0.45.3). But it got failed with the following error.

> During an aborted deployment, some instances may have deployed the new application version. To ensure all instances are running the same version, re-deploy the appropriate application version.

So we reverted back to the older version but now we are getting this error

FYR - We've deployed it through AWS beanstalk.

Diagnostic Info -

  "browser-info": {
    "language": "en-GB",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.13+8",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "https://adoptium.net/",
    "java.version": "11.0.13",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.13+8",
    "os.name": "Linux",
    "os.version": "4.14.238-182.422.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.16"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.23"
    "run-mode": "prod",
    "version": {
      "date": "2021-12-16",
      "tag": "v0.41.5",
      "branch": "release-x.41.x",
      "hash": "fbfffc6"
    "settings": {
      "report-timezone": "Asia/Calcutta"

If anybody is aware of this scenario, please help.

You need to restore your application database to the state where it was on v41. Btw: please check why did the upgrade never complete

Thanks, it worked.
Is there any way such that we figure out why the new version deployment failed?

You need to get the logs of elastic beanstalk while it was deploying the new version

Hi Luiggi, I tried deploying it again, monitoring the logs for both of our metabase instances for the time being (mainly nginx logs), but couldn't find anything solid.
Getting this in the health section -

Incorrect application version "test-metabase-source-8(v0.45.3)" (deployment 15). Expected version "test-metabase-source-7" (deployment 14).
Process default has been unhealthy for 27 minutes (Target.ResponseCodeMismatch).

Can you please suggest something here?

you have something wrong on the application versions you're uploading to Elastic Beanstalk. I would suggest you look at that and try again