Use default schema in Snowflake queries

I’ve connected a Snowflake database to Metabase and can access all the tables in the Data Model. There’s just one schema defined in the connection (both in the Schema field and in the Additional JDBC connection string options field as schema=my_schema_name, see the attached screenshot).

However, whenever I try to query the tables, I need to include the schema name in the SQL, otherwise it doesn’t work.

  • select * from “my_schema”.my_table; -> ok
  • select * from my_table; -> error

Is there some way to set the “my_schema” as the default and only option for the database so that I don’t have to specify it in every select?

It would help us tremendously!


Hi @matlustsm
You are likely seeing this issue: - upvote by clicking :+1: on the first post