User Credentials needed for DB connection

Hello!

I created a user in my postgres DB with SELECT privileges, however that user is still not able to view data in the DB tables. I also tried giving this user ALL privileges, but that user is still not able to access data. Error that I’m getting is: ERROR: permission denied for table

I also have an admin user and that user is able to access all the data. Is this a known issue in Metabase (only admins can have access to the tables within metabase) or is there another setting I need to tweak?

I’ve attached a screenshot below of current settings. Thanks!

Hi @andysun1
Please post “Diagnostic Info” from Admin > Troubleshooting.
You can use read-only privileges for the data sources, since Metabase only reads data. I would recommend giving write options to session variables and temporary tables, since that might be needed.
Without knowing which database you are using, or the error log from your database, then it’s hard to know. Try using DBeaver.io or similar to see if that works.