V46.1 timeout issues

Any ideas when this will be solved? Missing some of the features from new version, but we had to move back to the older one because of those recent issues...

Looks like they don't have enough clue to understand and solve. I think it might be related to our (old) mysql version because we are not many impacted by this problem. What is yours ? (5.5.50 here)

@Luiggi is there anything we can do to help you reproduce or fix the problem ? 46 has several important features for us but we can't upgrade because of this :confused:

Thank you !

Quote from my last post on GH :

Problem still present in 0.46.3

More information : I looked at the process list to see generated SQL for :

  1. the run of the model
  2. the build of the cache (table) from the model

Both can't execute in 0.46.x but if I copy them and run them directly on the database with a mysql client it's running fine (the run AND the create table for the cache), something might have change on metabase code to add a timeout around queries.

After several test, it looks like timeout occurs between 30 and 35 seconds. There is no problem with smaller models, run and cache build are working correctly.

thank you, we haven’t had the time yet to reproduce and tackle this issue. I’ll try to find time soon to check for a consistent repro environment to check it out

We have the same problem . I have tried with mysql (AWS RDS) version 8 and cloud version of metabase.

we have identified the problem and fixed it. It will be available in 46.5


What is the expected date for launch this new version? (46.5)

Released yesterday

1 Like