Visualisation does not work if we filter in a certain month

The visualisation does not appear when I filter my dataset with month equal to March 2023 onwards. The error message is undefined is not an object (evaluating 'e.rows')
However, it works when I filter my dataset with month before March 2023. The er

I tried to do the same thing with the same query in Snowflake and I found it worked in snowflake.
So, my first hypothesis is that dataset or the data type in the data set has no issue.

Here is the video recording
Filter in the explore mode

I and my colleague tried several browsers & OS's:

  • Browsers: Chrome, Chrome incognito, Safari

  • OS: Windows10 and MacOS ventura 13.3

Could you please help us with this?

please post diagnostic info

Diagnostic info

"browser-info": {
"language": "en-GB",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.4 Safari/605.1.15",
"vendor": "Apple Computer, Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "",
"java.vendor": "Eclipse Adoptium",
"java.vendor.url": "",
"java.version": "",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "",
"": "Linux",
"os.version": "5.4.196-108.356.amzn2.x86_64",
"user.language": "en",
"user.timezone": "UTC"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "mysql",
"application-database-details": {
"database": {
"name": "MySQL",
"version": "5.7.37-log"
"jdbc-driver": {
"name": "MariaDB Connector/J",
"version": "2.7.6"
"run-mode": "prod",
"version": {
"date": "2022-09-02",
"tag": "v0.44.3",
"branch": "release-x.44.x",
"hash": "7d50282"
"settings": {
"report-timezone": null

Please upgrade to the latest version

Metabase has been updated to 0.46.1.
The bug is fixed.