Weird Snowflake convert_timezone behvaiour

Hi, when I run this query:

to_timestamp_tz('2022-01-01 00:00:00 Z') as timestamp,
convert_timezone('America/New_York', timestamp::timestamp_tz) as converted

in Snowflake, it converts from UTC to America/New_York with no problem.

However, when I run it in Metabase, it doesn't do anything - see attached image.

Any idea what could be the issue? I'm out of ideas.


Hi @matusp
Post "Diagnostic Info" from Admin > Troubleshooting.
Latest release is 0.42.4, which fixes another Snowflake issue.
But it sounds like you are seeing this issue: - upvote by clicking :+1: on the first post

Hi Flamber,

here it is:

  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.88 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "",
    "": "Linux",
    "os.version": "5.4.95-42.163.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "UTC"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "12.8"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.23"
    "run-mode": "prod",
    "version": {
      "date": "2022-02-28",
      "tag": "v0.42.3-SNAPSHOT",
      "branch": "?",
      "hash": "d6ff494"
    "settings": {
      "report-timezone": null

@matusp Okay, so you are using some custom build of Metabase. I cannot tell what changes have been made to that, so try official releases. And have a look at the issue I linked to.