We've noticed a new login on your Metabase account

Hi all,

I have been receiving notification emails telling me there is a new login on my account since this Friday (Maybe on which the DevOps upgraded the Metabase) and I do believe that a cronjob, which is running on the server fetching the latest data 4 times a day by calling the Metabase APIs, has been triggering those emails. So I was wondering if there is any way to stop these false alarms as the server IP has never changed. I have walked through the Admin settings on the Metabase with no luck and hence this thread.

## We've noticed a new login on your Metabase account.

Hi Mingjing,

We noticed a login on your Metabase account from a new device.

Library (Python-requests/unknown) - Canberra, Australian Capital Territory, Australia

April 24, 2021, 12:00:06 PM (Australian Eastern Standard Time)

If this was you, you can safely disregard this email. If this wasn't you, you should change your password immediately.


Mingjing Peng

Hi @pholmesp
Start Metabase with this environment variable set MB_SEND_EMAIL_ON_FIRST_LOGIN_FROM_NEW_DEVICE=FALSE
That will disable those emails from being sent for all accounts.


Hi Flamber,

Thanks for the prompt reply, will try that next Tuesday.


Your solution works like a charm. Thank you.

Possible to make this a feature in the admin setting instead of environmental variable?

@yesk13 There are a lot more settings in envvars than what are available in admin panel. Currently we are trying not to overload the admin panel with every setting.

@flamber any way to set that via settings api?

I tried setting this via the api and when I PUT to /api/setting/send-new-sso-user-admin-email? I get a 500

@apanzerj No, it's only possible to use an environment variable.


I set this via env var and I still get the new login email...

@apanzerj I can guarantee it works if you defined it correctly, where all the other environment variables are.
Post "Diagnostic Info" from Admin > Troubleshooting, and where you applied it, and restart Metabase since envvars are only read on startup.

Sorry. I think I forgot to restart the container after the env change!