Why does metabase want my smtp password in plain text?

I was trying to setup SendGrid as email provider for Metabase. According to SendGrid documentation the username and password (api key) should be base64 encoded.

I did the following

  • I entered my details in metabase then clicked save
  • Got a green button that everything was saved ok
  • Tried to send a test email from a pulse, got a green button that everything was ok

No email arrived so I checked the logs and I found this interesting message:

INFO metabase.models.setting Attempted to set Setting email-smtp-password to obfuscated value. Ignoring change.

What is the point of this? Why do you care about how my passwords look like and if they are obfuscated or not?

I mean…I hope my passwords doesn´t leave my metabase instance…right?

Hi @AndreJ82

Please post “Diagnostic Info” from Admin > Troubleshooting.

Your connection credentials - database, email, etc - are not send to other places than the hosts configured, if that’s your question.

Have you tried to send a test-mail from the setup? Admin > Settings > Email
Also check the log for more details. Admin > Troubleshooting > Logs

You should only be seeing that error, when trying to save a password that contains 10 characters of * (wildcard character), and two other characters:
This could happen in case of form re-save or a form/password manager doing something it shouldn’t in your browser.