Wrong labels on date histogram

I would like to see December column before January column because it is December 2018, I mean the actual December column should be empty because it is December 2019 and I still have no data.

@fabiano.dagostino
Are you using Timeseries or Ordinal in visualization Settings > Axes > X-axis scale?
If you return year-month, then you should get the correct order, but when you only return month-name, then it doesn’t know December is from previous year.

I return year-month, but it is not in the correct order and in Settings > Axes > X-axis scale I have Linear.

@fabiano.dagostino
Which version of Metabase? And which browser? And which language?
I’m asking for the X-axis scale - not the Y-axis.
And I still don’t know how you’re able to only show month-name, when you’re returning year-month.
It looks like you are only returning month, so what is the raw-data you are returning - January or 2019-01 or …?
Have you tried setting it to Ordinal?
This is how it would look if you returned year-month on Timescale:

I don’t have the option Timeseries and my group by is month of the year.
Anyway Metabase version 0.33.5.1, Google Chrome, Italian.
menu

@fabiano.dagostino
Okay, you are using “Month of year”, which only returns a month number (which Metabase converts to a month name).
You should be using just group by “Month”, when your data is overlapping years.

Yes, thank you!