Y-axis manual range not working if X-axis is Timeseries

Hi,

In this chart, X axis is “Timeseries” and I set Y axis range as Min 90 and Max 105. This is not reflected in graph. To be precise

  1. Negative Min values are shown. All positive Min values are ignored and 0 is taken
  2. Max values are working fine

If I change X axis to “Ordinal”, the min/max values of 90 to 105 are properly reflected.

{
  "browser-info": {
    "language": "en-US",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "file.encoding": "Cp1252",
    "java.runtime.name": "Java(TM) SE Runtime Environment",
    "java.runtime.version": "1.8.0_241-b07",
    "java.vendor": "Oracle Corporation",
    "java.vendor.url": "http://java.oracle.com/",
    "java.version": "1.8.0_241",
    "java.vm.name": "Java HotSpot(TM) 64-Bit Server VM",
    "java.vm.version": "25.241-b07",
    "os.name": "Windows 7",
    "os.version": "6.1",
    "user.language": "en",
    "user.timezone": "Asia/Calcutta"
  },
  "metabase-info": {
    "databases": [
      "h2",
      "mysql"
    ],
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      },
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
      }
    },
    "run-mode": "prod",
    "version": {
      "tag": "v0.35.3",
      "date": "2020-04-21",
      "branch": "release-0.35.x",
      "hash": "1d424cb"
    },
    "settings": {
      "report-timezone": null
    }
  }
}

Hi @Krishna
You’re likely seeing this issue:
https://github.com/metabase/metabase/issues/10434 - upvote by clicking :+1: on the first post

Hi @flamber

Actually the issue seems to be caused due to missing data in my timeseries. I filled data for all the dates, the manual Y-axis range started working fine!

Not sure whats the connection, but for now its fine. Thanks for your prompt support :+1: