Connect to secured Presto server


#1

I have a Presto server cluster secured with HTTPS/SSL and LDAP authentication. The server address is like https://coordinator.presto.cluster.local:30443/ and you need to enter valid Windows Domain username/password to access it.

When I enter the Presto server information in Metabase, I found nowhere I can specify HTTPS connection should be used. After I enter host name, port, database name, username and password and clicked “Next”, I get two different messages:

  1. If I check “This is a large database, so let me choose when Metabase syncs and scans”, I get “Couldn’t connect to the database. Please check the connection details.”
  2. If I don’t check “This is a large database, so let me choose when Metabase syncs and scans”, I get “org.apache.http.ProtocolException: The server failed to respond with a valid HTTP response”.

Either way I can’t save the database settings and move to the next step.

Is secured Presto server supported by Metabase? If not, do you have plan to add this capability?


#2

+1 I am also using Presto with Metabase and would like to know the answers to these questions.


#3

The :blue_book: Admin Guide page on Managing Databases has a section Secure Socket Layer (SSL) mentioning that by default Metabase tries to connect securely first. If we do a bit of code spelunking we see both the current generic UI frontend and Presto driver specific backend code seems to support that statement.

So, yes it should be supported. (I’ve never tried Presto myself - yet - though)

There’s an excellent Troubleshooting Guide section on database connection problems:

Let us know how it goes!