App embed on enterprise version with error SSL_ERROR_RX_RECORD_TOO_LONG


I follow the instructions on file from route . I run on OS Ubuntu v20.04. I got the error SSL_ERROR_RX_RECORD_TOO_LONG on both routes https://localhost:3000/ and https://localhost:3001/. Could you consult your developers for support?

Best regards.

Hi @brunolnetto
You cannot use https on localhost. Basically anything involving localhost nowadays causes a lot of CSP errors in most browsers, so it's recommended to use real domains.

Again, just to make it perfectly clear: You are following an example for the Enterprise Edition of Metabase.
You should not follow that example, you should use

We have been over this several times. You should hire a web developer to help you.

I am in the Enterprise Edition. What should I change instead of localhost to make the application available on the example to work?

@brunolnetto If you are using the Enterprise version, then go through the sales process and support will be provided:

You cannot use https:, you have to use http:, when working with localhost.

I apologize for the spam-like messages, but the web developers are concerned with build-up features of the business. I was able to build the app on this URL Thank you!

I was partially successful to alter the example provided on the previous post. The respective iframe field appears the message "Embedding is not enabled for this object.", although I enabled embedding option in Metabase admin > "Embedding in other applications".

@brunolnetto Go and enable sharing on the dashboard/question:
The icon has just been changed to an arrow-up-left (:arrow_upper_right:) - the documentation hasn't been updated with new images yet.

I enabled the button respective to "Enable sharing", but still appearing the message "Embedding is not enabled for this object." on the application.

@brunolnetto Pretty please. Read what is says. Click "Embed this dashboard/question in an application".
That is how you embed. Otherwise you have just enabled Public Sharing, which is something completely different.

Like I have said multiple times. Contact a web developer to get help. If you are a new web developer, then ask someone more senior than you. Metabase is not a great beginner project.

Sorry, I misread. But as I said 4 posts before this, the "Embbed in other applications" button is enabled since I accessed the Admin menu and performed this action beforehand.

@brunolnetto I would recommend that you read everything again. And if it is not working, then read it again:

Enabling embedding in the Admin panel is just one step.
Then you need to enable it for every dashboard or question you want to embed.

There's many thousands of installations of Metabase and many thousands are using embedding.

I can not replicate what I can not read. I mean, there is nowhere explained how to enable it for every dashboard or question I want to embed.

The user chrisgauthier74 has the same issue a long time ago, in a galaxy far away.