Cannot load question in pulse

This is similar to another question: Impossible to load question in pulse

I want to add two questions to a pulse. These two questions are virtually identical, but one would result in no data returned (expected behavior, since I haven’t got any data in them yet), while the other question would result in an eternal spinning wheel. Selection_066

From logs, the error message is:

[92aa0c3a-2694-4763-9ec2-0e376a06b73a] 2020-07-01T12:15:25+07:00 ERROR metabase.middleware.log GET /api/pulse/preview_card_info/509 500 161.6 ms (7 DB calls) 
{:message "**Unexpected character (',' (code 44)): Expected space separating root-level values**\n at [Source: (StringReader); line: 1, column: 6]",
 :type com.fasterxml.jackson.core.JsonParseException,
 :stacktrace
 ["com.fasterxml.jackson.core.JsonParser._constructError(JsonParser.java:1804)"
   ...
"server.proxy$org.eclipse.jetty.server.handler.AbstractHandler$ff19274a.handle(Unknown Source)"]}

As seen on the error log, the problem is “Unexpected character (’,’ (code 44)): Expected space separating root-level values”. This seems different from the zero-date issue explicated in this other bug report: https://github.com/metabase/metabase/issues/11665. I attempted to apply the workaround described on that thread to no avail.

Does anyone know of any workaround? Would this be solved in future release? Or did I do something wrong?

Metabase installation:

{
  "browser-info": {
    "language": "en-US",
    "platform": "Linux x86_64",
    "userAgent": "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:77.0) Gecko/20100101 Firefox/77.0",
    "vendor": ""
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.5+10",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.5",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.5+10",
    "os.name": "Linux",
    "os.version": "4.15.0-1056-aws",
    "user.language": "en",
    "user.timezone": "Asia/Jakarta"
  },
  "metabase-info": {
    "databases": [
      "mysql"
    ],
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      },
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
      }
    },
    "run-mode": "prod",
    "version": {
      "date": "2020-04-21",
      "tag": "v0.35.3",
      "branch": "release-0.35.x",
      "hash": "1d424cb"
    },
    "settings": {
      "report-timezone": "Asia/Bangkok"
    }
  }
}

Hi @sagungrp
Latest release is 0.35.4, so upgrade to that.

Looks like this issue, but without steps-to-reproduce it’s close to impossible to know what’s going on or how to fix it:
https://github.com/metabase/metabase/issues/12403

And migrate away from H2 if you’re using Metabase in production:
https://www.metabase.com/docs/latest/operations-guide/migrating-from-h2.html