Impossible to load question in pulse


I’m trying to add a question to a new pulse.
When I select the question, the loader starts but never ends even if the question only have one line and work perfectly when I open the question in another window.

I tried with other questions and some are working, but not every question loads in the pulse.

Thank you

Hi, does anybody have any info concerning this issue ?
Thank you.

Hi @alexkava85
Which version of Metabase? Please post “Diagnostic Info” from Admin > Troubleshooting.
Do you see any errors around the time of the failed loading? Admin > Troubleshooting > Logs

Hi @flamber, this is version 0.34.0
Here is the log file at the time of the loading
2020-02-11T15:47:38-05:00 ERROR metabase.middleware.log GET /api/pulse/preview_card_info/1896 500 2,0 s (18 DB calls) {:message "Unsupported field: MonthOfYear", :type java.time.temporal.UnsupportedTemporalTypeException, :stacktrace ("java.time.LocalTime.get0(" "java.time.LocalTime.getLong(" "java.time.OffsetTime.getLong(" "java.time.format.DateTimePrintContext.getValue(" "java.time.format.DateTimeFormatterBuilder$TextPrinterParser.format(" "java.time.format.DateTimeFormatterBuilder$CompositePrinterParser.format(" "java.time.format.DateTimeFormatter.formatTo(" "java.time.format.DateTimeFormatter.format(" "java_time.format$format.invokeStatic(format.clj:50)" "java_time.format$format.invoke(format.clj:43)" "--> pulse.render.datetime$reformat_temporal_str.invokeStatic(datetime.clj:14)" "pulse.render.datetime$reformat_temporal_str.invoke(datetime.clj:13)" "pulse.render.datetime$format_temporal_str.invokeStatic(datetime.clj:33)" "pulse.render.datetime$format_temporal_str.invoke(datetime.clj:16)" "pulse.render.body$fn__32751$format_cell__32756$fn__32757.invoke(body.clj:46)" "pulse.render.body$fn__32751$format_cell__32756.invoke(body.clj:43)" "pulse.render.body$fn__32824$query_results__GT_row_seq__32829$fn__32830$iter__32831__32835$fn__32836$iter__32869__32873$fn__32874.invoke(body.clj:97)" "pulse.render.table$render_table_body$iter__32665__32669$fn__32670$iter__32703__32707$fn__32708.invoke(table.clj:75)" "api.pulse$fn__65440.invokeStatic(pulse.clj:166)" "api.pulse$fn__65440.invoke(pulse.clj:159)" "middleware.auth$enforce_authentication$fn__48819.invoke(auth.clj:14)" "routes$fn__67566$fn__67567.doInvoke(routes.clj:56)" "middleware.exceptions$catch_uncaught_exceptions$fn__48775.invoke(exceptions.clj:104)" "middleware.exceptions$catch_api_exceptions$fn__48772.invoke(exceptions.clj:92)" "middleware.log$log_api_call$fn__48685$fn__48686.invoke(log.clj:178)" "middleware.log$log_api_call$fn__48685.invoke(log.clj:172)" "$add_security_headers$fn__48736.invoke(security.clj:121)" "middleware.json$wrap_json_body$fn__48904.invoke(json.clj:64)" "middleware.json$wrap_streamed_json_response$fn__48922.invoke(json.clj:100)" "middleware.session$bind_current_user$fn__47354$fn__47355.invoke(session.clj:209)" "middleware.session$do_with_current_user.invokeStatic(session.clj:184)" "middleware.session$do_with_current_user.invoke(session.clj:177)" "middleware.session$bind_current_user$fn__47354.invoke(session.clj:208)" "middleware.session$wrap_current_user_id$fn__47339.invoke(session.clj:161)" "middleware.session$wrap_session_id$fn__47283.invoke(session.clj:125)" "middleware.auth$wrap_api_key$fn__48827.invoke(auth.clj:27)" "middleware.misc$maybe_set_site_url$fn__48800.invoke(misc.clj:56)" "middleware.misc$bind_user_locale$fn__48803.invoke(misc.clj:72)" "middleware.misc$add_content_type$fn__48788.invoke(misc.clj:28)" "middleware.misc$disable_streaming_buffering$fn__48811.invoke(misc.clj:87)")}

Thank you

here the diagnostic info
“browser-info”: {
“language”: “fr-FR”,
“platform”: “MacIntel”,
“userAgent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.87 Safari/537.36”,
“vendor”: “Google Inc.”
“system-info”: {
“”: “Java™ SE Runtime Environment”,
“java.runtime.version”: “1.8.0_201-b09”,
“java.vendor”: “Oracle Corporation”,
“java.vendor.url”: “”,
“java.version”: “1.8.0_201”,
“”: “Java HotSpot™ 64-Bit Server VM”,
“java.vm.version”: “25.201-b09”,
“”: “Linux”,
“os.version”: “4.15.0-72-generic”,
“user.language”: “en”,
“user.timezone”: “Etc/UTC”
“metabase-info”: {
“databases”: [
“hosting-env”: “unknown”,
“application-database”: “h2”,
“run-mode”: “prod”,
“version”: {
“tag”: “v0.34.0”,
“date”: “2019-12-19”,
“branch”: “release-0.34.x”,
“hash”: “1335215”
“settings”: {
“report-timezone”: “Canada/Eastern”

I would recommend that you upgrade to 0.34.2 - there’s several other issues fixed, not related to this.

Then you should migrate away from H2 as the application database:

Which database are you querying in question ID 1896? And is it a Custom or Native question?
It gives the error Unsupported field: MonthOfYear, which I have never seen before, so do you know if there’s a column or variable/parameter in the question by that name?

Hi @flamber, Thanks for your answer and sorry for the delay.

I upgraded to 0.34.3

I’m kind of stuck with my H2 database, I didn’t managed to change it to MySQL, but it’s another issue.

It’s a simple question which is from a view of my SQL server database.
There’s no column by that name. My question has only 5 columns (Driver, Date, Start, End, Vehicle).
I changed the format of Date, Start and End to Date and Time respectively.
Maybe the problem comes from my view ?

Thank you.

I’m not sure what’s going on. I haven’t seen that error before, so I’m not sure where it’s coming from, but I think it might be somewhere in Metabase.
What’s the actual database column type of the 5 columns in that view?
I don’t know what else to ask - you might need to do a little debugging yourself.

Hi @flamber, thanks for your answer, I’ll see what I can do

Hi !

I could recreate the bug, and fixed it by removing the temporal columns of my request.

When I query including date columns, I get the same error as you. If I remove those collumns, I am fine.

I have worked around it by adding a custom collum = concat([date],"") so the script believes it is a string, and not a temporal column.

Tell me if that works for you !

@devlikin You're likely seeing a different issue, which is fixed and will be part of next release:

EDIT: There's now a specific issue for the "Unsupported field: MonthOfYear" issue: - upvote by clicking :+1: on the first post

You’re right. Fix still works for now :slight_smile: