Cannot set SQL requests read-only permission

Similar to this question
I have the same problem where I cannot seem to give a group the permission to be able to only read SQL queries without writing them, as described here.

From what I understood from the previous question granting full access to the database should suffice to be sure that the group can read SQL queries, which is not the case here.

Moreover, I made sure I couldn’t just set specific table access for the group and then give them the right to write SQL queries, which is confirmed by a message before allowing “write raw SQL queries”
image

(Sorry, I would have added more images to illustrate but as a new user I am limited to only one)

Hi @LoicM
I can see what you mean (0.32.9). There’s no “Read SQL queries” option. I’m almost 100% sure this was changed as part of Collection 2.0. Most was implemented in 0.30.0, but there’s still a few outstanding issues.
So, since you cannot have “read-only” to a database - you either have option to write SQL or not.
I can see the documentation needs an update.

1 Like