Columns have changed to json objects


We recently upgraded our Metabase environment to and see this issue occurring for this particular table. See below screenshot the tables column have changed to Json objects but when I run a select query on the same table the

Then the results seem to be fine. Please could someone help me out with this issue. Thanks

@flamber Please could you help in this issue

Here's another post in the forum that might be helpful to you How to turn off "Native JSON record support in Postgres" feature introduced recently

Hi Luiggi,

Thanks for your response. But I wanted these above columns the ones like Object Changes-> MC Retail Price and other to be captured permanently. When I run the select query the updates are getting clubbed into a single query with the name as 'Object Changes'

when Metabase runs GUI queries, it builds the queries with json unnesting on its query processor, it does not build a view or a materialized view.

if you would like to achieve what you're saying, build either a model in Metabase or a view/materialized view in the database

1 Like

So metabase is unnesting the json itself. If I create a view I would have to unnest the Json array into columns in that view right. Or how could it be done please could you elaborate?

yes, create a database view or a metabase model where you manually unnest the json. Once you do that you'll be able to do what youre looking for