Dashboard Subscriptions not sending to Slack or Email

Having an issue where Dashboard Subscriptions do not send to either email or Slack automatically - clicking "Send Email Now" DOES work, but the automated subscriptions do not.

My Slack integration seems to have worked considering that the list of channels populates correctly when I go to configure a Dashboard Subscription (yet no actual subscription messages are sent to the channel I select).

I haven't used any Pulses given their deprecated state, so this is Dash Subscriptions only.

This seemed similar to the following issue, but no resolution was posted, so I wasn't sure how this got solved:

Our Metabase instance is a Managed Cloud - Starter one. See below for Troubleshooting - Diagnostic Info, and let me know if more info is needed to help investigate/resolve!

{
  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.106 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.11+9",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.11",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.11+9",
    "os.name": "Linux",
    "os.version": "4.14.219-164.354.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  },
  "metabase-info": {
    "databases": [
      "mysql"
    ],
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.9"
      },
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.18"
      }
    },
    "run-mode": "prod",
    "version": {
      "date": "2021-05-17",
      "tag": "v1.39.2",
      "branch": "release-x.39.x",
      "hash": "b0d9436"
    },
    "settings": {
      "report-timezone": null
    }
  }
}
```*emphasized text*

Hi @jasongraph
Can you post a screenshot of "metabase.task.send-pulses.job" from Admin > Troubleshooting > Jobs?
The other topic that you linked to, was most likely having problems with the email configuration or server - that is handled automatic via Metabase Cloud.

Yup - here are screenshots of that page and the View Triggers modal:

And for good measure, here's a screenshot of a Dashboard Subscription cfg that should be sent to Slack hourly (I've tried both public channels and DM ones, no difference) where I've gotten nothing:

57%20PM

Let me know if any more info is needed!

Hi @jasongraph
You are seeing this issue, which has been very difficult to find the root cause of:
https://github.com/metabase/metabase/issues/10088

I don't have a fix for this, besides restarting the instance, which you can request from support (there will be 3-5 minutes of downtime): https://store.metabase.com/support

Understood and thanks, will request that support restart the instance.

Hi @flamber

I'm having the same issue but don't seem to have a Metabase cloud account. My org's database lives on https://metabase.getwarmly.com/ - how do I get help restarting the instance?

@shep

  1. Post "Diagnostic Info" from Admin > Troubleshooting.
  2. Change the Site URL to match your address in Admin > Settings > General.
  3. Update Metabase - latest release is 0.40.2
  4. As for restart, you need to contact the person who's administrating your instance. Or migrate to Metabase Cloud, so hosting is managed for you, but that will still require access to the instance in order to migrate.