How to use data of existed dataBase

I want to use the information of a database that exists.
I wanted to connect to a pre-existing database via admin » DATABASES » ADD DATABASE but was unsuccessful and I faced the connection refused error.
What can I do to for connecting the database and use that information??

Hi @rezza
Post "Diagnostic Info" from Admin > Troubleshooting, and which type of database you're trying to add.
There's likely network problems - like a firewall or problems with DNS.
Check the log for full error details - Admin > Troubleshooting > Logs.

1 Like

@flamber Thanks
At first, I had a problem connecting to the database during the installation step which is solved.
But now, I want to use a database inside the Metabase to show the data and I can't.
I use Mysql for the MetaBase database.
Also, I used Mysql for the database that I want to use its data and tables.

THIS is the log for full error details.

@rezza You are not inputting a Host that Metabase should use to connect to.
It's exactly the same as I explained in your previous topic: Connection refused to database mysql

[f93f2c97-6de0-4da4-9725-42c19de7ce01] 2021-08-23T14:01:43+04:30 ERROR metabase.driver.util Database connection error java.sql.SQLNonTransientConnectionException: Could not connect to address=(host=)(port=3306)(type=master) : Socket fail to connect to host:, port:3306. Connection refused (Connection refused) at ...

And post "Diagnostic Info" from Admin > Troubleshooting.

1 Like

That problem is about the Metabase installation And I realized I must use db instead of localhost.
That problem is solved when I use db.

Now, I want data placed in a existed database.
I tried db for this issue, but it didn't solved it.

oh, sorry I forgot to post the Diagnostic Info.
HERE you are.

I don't understand, but since you have made changes and something is working, then I'm guessing that you're seeing a different problem, so post the logs (Admin > Troubleshooting > Logs) for that.

If you are not familiar with Docker, then I would highly recommend that you use JAR instead: