[More than one appears list of Dashboard on collection]

Hi Guys,

First of all thank you for metabase community.

Currently we have done to install metabase with version v0.48.4. and when we look at in the collection, the view for the dashboard appears more than once (duplicate), but if we check and click to the dashboard, the dashboard id and the result still same

Maybe someone have the same problem with me or anyone have advice for this?

Thank you

@ade.kurniawan could you please try to clear your browser cache?

Hi @leeloo

Thank you for your response, I have tried to clear cache my browser and open in incognito, but it's still same :pray:

I'm getting the same but not always 2 and not always the same number!
I had one question shown 9 times. Refresh dropped it to 5.
It is definitely the same question (same ID in url) so looks like a problem in the UI.
Renaming seems to fix it - could this be a problem with having questions with the same name in different folders?
Edit - renaming, then changing back to original name also works!

This is interesting. I'm unable to reproduce this locally so it's hard to say for certain what could be happening. If either you are able to reproduce this could you share your Metabase version and exact steps to reproduce?

Thank you!

Hi Andrew,

I have tried what you did, and it's works. :pray:

Thank You.

Hi Leeloo,

I'm using docker to install this version v0.48.4, and used the database previous version (backup database). And then, it's happened when we check in collection using UI after the setup finished and running well.

Thank you

Mine's a bit more complex as it's running on an old version of Windows (2008 - don't ask...)

Old version was MySQL 5.7. That made the upgrade fail with syntax errors.
Upgrade to latest MySQL and restored backup from 5.7. Bit more awkward as mySQL UI doesn't work in such an old version of Windows.

I've other instances to upgrade, including my development instance so should be able to test to see how often it happens. The rest are running Postgres.

Bit more testing.
I've upgraded 3 instances.
One that was previously running MySQL5.7, upgrade to MySQL 8.0 - duplicates/triplicates etc
One that was already running MySQL 8.0 - duplicates/triplicates etc
One running Postgres - works perfectly.

Assuming @ade.kurniawan is also running MySQL, looks like that could be the problem.

I'm have the same issue here. We're running MySQL 8.0 too.

Just started a v38, did a few x-rays and saved those (app db MySQL 8)
Then moved to v48.6, no problem at all

can anyone help me to understand what could be the problem?