New MySQL DB tables not showing up

Our devs are allowing access to new tables in a configured MySQL database on Metabase. I can see the original tables that were setup, but even after triggering a sync - I cannot see the new ones.

Are you getting the same issues that I am getting? My setup is also mysql, it only fails after the first sync.

I added the DB again in a test instance (clean) of Metabase… same issue. It’s only detecting some of the tables but none of the recently added ones. Very odd… I can confirm the tables are OK by connecting via MySQL Workbench.

Possibly related to this issue:

And over on GitHub this issue:

Try going to the data model first, view the tables, then go back to the question builder.

Tried that too. The issue is that I can’t see the tables in the data model section.

Have you tried connecting directly to the database with the user in your Metabase connection and verifying that that particular user has been granted access to the new tables?

Maybe it is an issue with the tables visibility in the Data Model section?
I had the same issue, but my problem was that the tables where hidden with value reason Technical Data.

Same here. Tried with MySQL Workbench with the same credentials as metabase has, and no luck. I can see the new tables and views, I re-scan the fields values, sync the DB schema but nothing happens

This might just be a browser cache issue, so try refreshing the browser.
Otherwise, have a look at this comment about enabling more debug logging and doing a new sync, while checking the log for errors: Latitude and Longitude fields won't autobin

Wow! Really? Browser cache?:rofl: