pulses don't send automatically


#1

Hi all,

Metabase don’t sent the pulses at the scheduled date.

If I send the pulse manually (with test pulse button), this work correctly, but are doesn’t send automatically.

  • Your browser and its version: Firefox 65
  • Your operating system: Ubuntu
  • The type of database(s) you’ve connected to Metabase: postgresql
  • The version of Metabase you’re running: 0.31.2
  • Metabase hosting environment: Ubuntu
  • Metabase’s internal database type: postgresql
  • Repeatable steps to reproduce the issue: Create a pulse to receive automatically and save it

#2

Hi @jjponz
What do you see in the Metabase log?
What type of Pulse are you using - Slack or email?


#3

Hi @flamber,

the logs are empty about the pulse… I had configured the pulses to send at 14:00, and at this time the log don’t say anything about pulses or similar.

The pulse is a daily pulse, and, if I restart metabase, the first time the pulse send automatically, but this doesn’t happen again…

Someone has this problem?


#4

@jjponz

What type of pulse is it, email or Slack?

Does it run at a different time than at 14:00 ? I’m thinking that it’s a problem with timezone, so have you let it run for 24 hours?


#5

Hi @flamber:

Sorry for the delay, the pulse is a email pulse, and it’s configured to send ever 24 hours, at the same hour.

How I can check if it’s a problem with timezone?

Thanks


#6

Hi @jjponz

You can run this command on the Ubuntu server to show timezone information.
timedatectl status
And then you need to check your Metabase Settings > Admin > General > Report Timezone.

Could you check you mail server log to see if the mail is being sent from Metabase at the selected time? Just to make sure it doesn’t get chewed up in spam filters.

When you go and click the “Send email now”, you should see something like this in your log:

02-18 07:04:56 DEBUG metabase.middleware :: POST /api/pulse/test 200 (242 ms) (12 DB calls). Jetty threads: 8/50 (3 busy, 4 idle, 0 queued)

And make sure you don’t see any warnings or errors around the same time.

There was multiple reports about pulse problems about half year ago (version 0.29), but I haven’t seen much since then. There was one who said pulses didn’t work until he rebooted the Metabase server.


#7

Hi @flamber,

my timezone is Europe/Madrid .

The mails are sending via an external provider, then, i can’t view the logs.

When I click over “Send email now” i obtain the next in the logs:

aqui van los logs

and now, the pulses continues without sending… :frowning_face:

what can i do?

regards and thanks for all


#8

@jjponz
That is really strange, I’m not sure what’s going on then. You forgot the logs…
Let’s open an issue on this and hope the developers have some new ideas.
https://github.com/metabase/metabase/issues/new


#9

@jjponz
I found a couple of open issues, which seems that this problem relates to timezone:
https://github.com/metabase/metabase/issues/7682
Are you running Metabase in docker or directly via jar-file? Please make sure all your timezones are correct - and there’s multiple of them.
https://www.metabase.com/docs/latest/troubleshooting-guide/timezones.html

EDIT: Also have a look in Settings > Admin > Troubleshooting. You should be able to see the pulse (both the test and scheduled) and click details.
EDIT 2: Actually it looks like 0.31.3 was released a few hours ago, which adds Pulse logging to Troubleshooting - haven’t tested, just looked at the code.


#10

Where can I find this new version 0.31.3 for Elastic Beanstalk? I’m having a similar issue where pulses occasionally don’t go to slack at the scheduled time and would like a bit more visibility.


#11

Hi @dfine
I don’t think there’s a 0.31.3 image for EB. It seems like the version was created to help troubleshoot issues. It hasn’t been officially announced.
But it will be part of 0.32, when it’s released.
Have you gone through the timezone troubleshooting guide?


#12

I confirmed that it uses UTC on both the container and host. Most days the pulse slack appears at the expected time. Some days it doesn’t appear. It’s worth noting that some of the queries average 50 seconds. I’ve not found anything suspicious in the logs.


#13

Hello all,

I am having same issue for 15 days. Automatic mail pulses are not working at all. But when i trigger manually mails are sent.


#14

Make sure you’re using the latest version 0.31.2
If pulses used to work, but suddenly stopped sending, then it might be a problem with a stale database connection - try killing all database connections or restarting Metabase.

Also read these issues and upvote by clicking :+1: if it fits your problem:
https://github.com/metabase/metabase/issues/7389
https://github.com/metabase/metabase/issues/7682


#15

I feel like I may have a similar issue and am on the current 0.31.2 release too.

On Tuesday I had setup a new daily Pulse to be sent at 8 AM and yesterday and today I didn’t receive a message (although sending the Test email of the Pulse did work fine and I know the SMTP configuration is all up and running fine).

I also have the Report Timezone setting in the General configuration area set to US/Pacific in Metabase.

I’ve reviewed those two Github Issues as well. What I can do is try and restart Metabase later tonight and see if the Pulse runs correctly tomorrow at 8 AM which might indicate our issue is the “stale database connection” situation.


#16

Just to report back on my experience. I forgot to restart the Metabase service last night so I still didn’t get my expected 8 AM Pulse. Once I remembered to do so about 40 minutes (shortly after 9 AM) I updated the Pulse time to go out at 10 AM so I could more quickly see if things would work, then went ahead and restarted the Metabase service and waited.

I just received the Pulse so the issue seems to be fixed by restarting the Metabase service so hopefully you guys can figure out a long term fix for that issue since that’s a pretty core function that should work reliably for the system.

Also…would it be difficult to make it so users could have more flexibility regarding the times the Pulses go out? I hadn’t noticed till today but because the times can only be set in 1-hour increments it caused a longer wait time for my test since I couldn’t just set the time at 9:30 AM or whatever increment was closest.


#17

@omar.ramos
There’s a lot of changes in the upcoming 0.32 for troubleshooting various tasks. This should hopefully help with finding stalled tasks.
There’s a feature request for adding more timing control to Pulse - go and upvote by clicking :+1:
https://github.com/metabase/metabase/issues/3846


#18

Thanks @flamber,

I’ve upvoted that other feature request you shared. Hopefully the 0.32 release helps out (or at least gives us more info to troubleshoot things further and help you guys to find the long-term solution).


#19

@flamber,

One thing I’m also going to give a shot (based on the 3846 issue you shared) is the Alert feature for Questions which I haven’t even noticed/tried out before. Looks to be quite similar to the Pulses (so it may have the same underlying issue requiring the restart of the Metabase service described in this thread) but I think it’s also another useful feature to know about since it seems to have a similar, but different use case.

From the documentation:

It’s a really common thing to keep tabs on a metric over time, and to want to be alerted when it goes above or below a specific value, or goal. To set up a goal-based alert in Metabase, all you need to do is create a time series question and add a goal line to it in the visualization settings, then click on the “Get alerts about this” option in the new top-right menu. You can also get goal alerts when you create a progress bar question.

Another situation where you might want to get alerts is when you have a question that returns rows in a table that match a certain condition. It might not usually return results, but you want to know when it does. As an example, maybe you have a question that returns all the bad reviews users have given your product in the past 24 hours. Hopefully that question doesn’t normally have any results, but you can set up an alert on it and tell Metabase to let you know if there are any bad reviews for you to look at.