Snowflake driver test

I am a noob (so pardon the dumb question) but I tried out Metabase and liked it a lot.

I noticed there is a Snowflake driver for testing and I was wondering how I can test my companies Snowflake instance with Metabase’s connection to Snoflake.

Can anyone help here :slight_smile: ?

Hi & welcome!

I’ll take a shot at trying to guide you through. As long as you are up for and able to follow instructions on installing software tools and not afraid of working a bit on a command line I think it’s doable.

Currently you need to build the specific Snowflake branch of Metabase from source code from the GitHub repo indicated in the Pull Request (PR). So the overall steps of this involves:

  1. Installing tools to build Metabase as indicated in the PR here
  2. Download the Snowflake sources from the kenbier:add-snowflake-database GitHub branch (my recipe in the next step also has Git as a command line tool as a prerequisite) but it can be done in other ways)
  3. Build and run the code. I tried condensing this into a hotfix build script in my post here: Do we have a Metabase build with the last commits? (Note: this naturally needs adjustments for the add-snowflake-driver to replace to 0.28 hotfix one)

If you need more guidance (you said you’re a noob - which is helpful in guiding you :smile:) It would be helpful to know on what platform you are (Mac, Windows (version?), Linux etc). I know Windows for example has additional install requirements …

Let me know at what point you stumble and we can take the specifics from there if the above didn’t already scare you away :ghost:

We don’t currently officially support Snowflake, but as @jornh mentioned, there is a community PR.

We’ve reached out to Snowflake regarding testing infrastructure, and are awaiting a response.

1 Like

Good fair warning by @sameer here!

Understand it’s next to impossible for them and totally not fair to the awesome Metabase core team to ask them for any help on this. As with any community contributed additions that have not been included into an official Metabase release yet.

I’ll also add that if you try this out you shouldn’t do it on production data and systems etc. The risk is on you - if you break something you get to have the pieces. That’s all!

Haha not scared! but can tell I definetely will have lots of questions.

Will be taking a stab at this tomorrow.

And @jornh thank you so much.

I am running ubuntu.

I was following the instructions here and got up to the quick start.

got an error when I ran ./bin/build.

Error Uberjar aborting because jar failed: Cannot run program “make”: error=2, No such file or directory

where do I find the branch?

Told you I am a noob lol.

On Ubuntu if make isn’t already installed I think it’s in build-essentials - so try apt install that.

This branch in kenbiers fork:

Either download it directly or google how to fetch a PR (I’m on mobile right now so a bit brief answer here)

going to use the terminal and fetch PR. I just couldn’t find the kenbier branch.

@jornh if you are ever in NYC let me know because I will buy you lunch man.


You’re most welcome!

Never been to the big Apple yet, only the west coast so far, when traveling to US. Maybe I should try rectifying that one day? :slight_smile:

Hey @jornh I fetched the branch and built and ran the code. But when I went to add database I did not see the snowflake connection addition.

What else do I need to do?

Hmm, not really any good ideas, maybe apart from looking for that you see Snowflake in build output if you unzip the jar.

I’m sure now that you got this far kenbier on GitHub wouldn’t mind you reaching out.