[SOLVED] Cannot sign in using Google and being told I am not a user?

Hi, I have accessed my team’s Metabase account many times in the past by “signing in with Google”, but now I am having an issue where I click the button, select my team email, and then nothing happens I simply return to the log in page. I am attempting to log in on Chrome Version 70.0.3538.110 and running High Sierra Version 10.13.6. I tried to log in on Safari as well as a different laptop, and both of those times I received a message saying that I did not exist as a user. One of my team admins logged in and confirmed that I was in fact an active user and even tried removing me and re-adding me, and that still didn’t work.

Hi @davedef9
Which version of Metabase? Have you tried to login via Chrome in Incognito-mode, since it might be a lingering Google cookie that is messing something up.

Hi flamber, yes I did actually try that and just tried again, still just going straight back to the login page after i log into my email

@davedef9 Try to go to your Google settings and remove Metabase, so you have to grant access again - try Incognito, login to Google, goto https://myaccount.google.com/permissions, remove Metabase sign-in, then try to login to your Metabase by clicking the Google-button.

Just tried, still got the same thing :frowning:

Do you see anything in the Metabase log?

Hey @flamber, I’m the sysadmin for @davedef9’s account.

We’re running Metabase 0.28.6, deployed to AWS. I checked out the logs when Dave’s account attempts to log on, and this is the output:

Dec 06 15:13:01 INFO metabase.api.session :: Successfully authenticated Google Auth token for: Dave McNeeley
Dec 06 15:13:01 DEBUG metabase.middleware :: POST /api/session/google_auth 200 (56 ms) (2 DB calls). Jetty threads: 8/50 (3 busy, 5 idle, 0 queued)
Dec 06 15:13:01 DEBUG metabase.middleware :: GET /api/user/current 401 (121 µs) (0 DB calls). "Unauthenticated"

Steps I’ve tried taking here so far include:

  1. Removing Dave’s user from the list of known users in the admin panel
  2. Restarting the App Server for our Metabase instances in ELB

Scratch that. Fixed it by re-adding Dave’s account inside of the admin panel. Most likely removing the app from Google and re-signing in would have solved it, and I probably made things worse by removing his user.

All set! Thanks for your help!