Using regular gmail as email sender

I saw here https://github.com/metabase/metabase/blob/master/docs/administration-guide/02-setting-up-email.md that it is possible to use Google Apps for configuring email.
Is it possible to use a regular GMail account for configuring email?

Unfortunately not. You need to have access to an SMTP server that you can use to send Metabase emails.

I was able to use a personal Gmail. Here’s how:

  1. The very first thing you will need to do is ensure that you have 2-step verification enabled on your primary Gmail account. Important: If you don’t do this you will get an invalid password error further below when trying to authenticate your email address. So first go and enable 2-step verification.

  2. Next, you will need to generate an App password. You then use the app password in place of your personal Gmail password further below. This is the only way this process will work.

  3. Here’s the Metabase settings that you now use:
    SMTP Host: smtp.gmail.com
    SMTP Port: 587
    SMTP Security: TLS
    SMTP Username: GMail account (email@gmail.com)
    SMTP Password: The App password that you previously generated

Followed these steps exactly. Didn’t work. Already using the same gmail account for a Mail Merge activity on the MS Office suite. Can’t figure where the catch is.
Please advise.

Thanks
Rahul

Brian,
Followed the 2-step authentication and setup of apps 16 character password. Did not work as you stated.
Can you confirm you instructions again. I did this with a fresh gmail account. I saw something in google documentation that the username has to pass the CAPTCHA screen. Although i don’t get this anywhere.
Please help if you can
Chuck

Rahul,

did you get this working?
thanks,
chuck

@crwheelr
Do you see any errors in the Metabase log?
Try using the username and apps password in a regular mail client, since it has more logging than Metabase.
It might be that the Gmail account has some limitation, since it’s a fresh account, and Gmail is trying to prevent outgoing spam.

Hi flamber,

still working on this one. I would think that many MB users have succeeded in getting this working. i will keep hacking at it and post when i have it. Still a bit confused about the apps password thing with gmail. it assigns one, but requires a type to be entered. wondering if this is relevant.
And then there is some documentation with Google that the username needs to be submitted to the CAPTCHA program, hmm.
chuck

@flamber,
I set this up with MS Outlook using TLS and port 587 as specified by gmail docs, and using apps password. sends and receives nominally.
Retried in Metabase email setup and scanned the log. Pertinent message is "Error Metabase email::Error testing SMTP connection as captured below. MB cannot make the TLS connection. i tried it with SSL and correct SSL port and same kind of error occurs.

@crwheelr
And you have selected “SMTP Security”=TLS in Metabase?
Looking at the error, it seems like Metabase is not even able to connect to smtp.gmail.com:587, so my first guess is something is blocking access (either a local firewall or your ISP).
I have just setup a test with one of my Gmail accounts on my local dev and it works, so something must be different in your setup.

Hi again @flamber,

Yes of course TLS selected and the correct port 587 being referenced as specified by the Gmail documentation. I tried a different mail client MS Outlook, with the same setup and it works file. Therefore not a firewall issue. Also I specifically opened port 587 for all apps in firewall settings. It’s perplexing that the base connection cannot be made.

Chuck

@crwheelr Which version of Java are you using? Run java.exe -version or if you’re using 0.33.3, then go and copy all “Diagnostic Info” from Admin > Troubleshooting

(i removed the dump) issue with with antivirus checker, see below

@crwheelr
The Java version is very outdated. It’s more than 4 years old, from April 2015. Upgrade to the latest version 8, or 11 if you prefer.
You wrote smpt.gmail.com - it should be smtp.gmail.com

downloaded version 8, Update 211, which indicates on the command line version query as build 1.8.0_221. This is correct?

running the email setup yields the same results that server smtp.gmail.com port 576 cannot be found. I have tried SSL security with its documented port same thing.

if I setup MB email using another smtp server, my business one under godaddy with NO SECURITY it works fine. I believe this has something to do with the security settings.

Note as per gmail instructinos using 3rd parts email client, its necessary to setup 2 level authentication and to generate an apps password… I did this and tested that is works with microsoft outlook

@crwheelr
You can check which version of Java you’re using in Metabase > Admin > Troubleshooting (if you’re using 0.33.3+)

The Gmail TLS port is 587, not 576, but I guess that’s a typo.

So you are hosting Metabase and running Outlook from the same computer?
Which antivirus/firewall are you using? Have you tried to disable it temporarily?

yes port 587.
my dev box has outlook, i just created another account in MSOutlook to test the settings and the Apps password.that was generated for me. all of that works with MSOutlook.
Using Avast.
Avast will not let me suspend shields remotely.(vnc)
I’ll try this tonight when returning to office.

It was Avast blocking the transmissions! Works fine if I disable all shields. Curious that MS Outlook could send. Have to look into Avast further.

thanks for the tips. Ready to display my first VAR solution to a few interested clients.

much appreciated @flamber
Chuck

1 Like

I am confirming that this method works. setup 2-step authorization on the account, then generate the apps password. use that password in the MB email setup and there you go. It was the Avast outgoing SMTP checker feature that was blocking it. only need to disable that for Avast.

Chuck

1 Like

My gmail has not worked. I tried another email provider and it worked immediately.

Seems google is restricting external smtp access. Some well known apps might be accepted by google but metabase is probably not (yet).